Thursday, October 7, 2021

Zoom Update Required by November 1

On Monday, November 1, 2021, Carleton Zoom users must, at minimum, be using version 5.5.0 (released February 2021) to ensure continued access to all Zoom meetings, including those within Brightspace. You can download the latest version of Zoom here.

Moving forward, Zoom will prompt users to update their software to ensure it is no more than nine months behind the current version at any given time. For example, if the latest version of Zoom was released in September 2021, those using a version released before January 2021 will be prompted to update. Teaching and Learning Services recommends regularly updating to the latest version of Zoom to receive the newest features, as well as any privacy and security enhancements.

If you need help with Zoom, don’t forget to visit the Zoom at Carleton support site.

Thursday, October 7, 2021 in , ,
Share: Twitter, Facebook

We're here to help you succeed online!

Use our services search to explore our many support services.